collapse

www.dimecitycycles.com


www.restocycle.com

www.CITYLIMITMOTO.com

www.jadusmotorcycleparts.com

www.bisonmotorsports.com

www.speedmotoco.com

www.cognitomoto.com

www.townmoto.com

www.sparckmoto.com

www.Moto-Madness.com

www.pistonsociety.com

www.steeltowngarage.com


Author Topic: 10k Ohm Plugs or Caps with Dyna Coils?  (Read 301 times)

Offline Finnigan

  • Posts: 1944
10k Ohm Plugs or Caps with Dyna Coils?
« on: Sep 30, 2017, 12:28:19 »
Trying to get my tach to work.  Its a Motogadget Chrono classic that has a digital signal pickup.  The needle reads 9k when I'm at idle and I'm confident wiring is correct.  I contacted Motogadget support and they said the issue is from electrical interference (like having satelite TV near power lines) and it would be fixed if I used resistor style spark plugs or switched from 5k ohm to 10k ohm.

I'm running EI and high output Dyna coils from Charlie's Place.  Charlie said the coils should have no problem with whatever caps I use, but I wanted a second opinion.

Thanks y'all

Offline yozzer74

  • Posts: 351
Re: 10k Ohm Plugs or Caps with Dyna Coils?
« Reply #1 on: Oct 01, 2017, 03:08:13 »
I had same problem  just fitted resistor plugs ok after

Offline Finnigan

  • Posts: 1944
Re: 10k Ohm Plugs or Caps with Dyna Coils?
« Reply #2 on: Oct 01, 2017, 11:55:40 »
Hey yozzer, good to hear that its fixable.  I put 5k plugs in last night and it made no difference.  Are you using 10k resistor caps also?

Offline yozzer74

  • Posts: 351
Re: 10k Ohm Plugs or Caps with Dyna Coils?
« Reply #3 on: Oct 01, 2017, 15:39:41 »
I just used the caps that came with the dynatec coils and resister plugs