collapse

www.dimecitycycles.com


www.restocycle.com

www.CITYLIMITMOTO.com

www.jadusmotorcycleparts.com

www.bisonmotorsports.com

www.speedmotoco.com

www.cognitomoto.com

www.townmoto.com

www.sparckmoto.com

www.Moto-Madness.com

www.pistonsociety.com


Author Topic: FAAAAAAACK!!!! I need British bike help!  (Read 838 times)

Offline ApriliaBill

  • Posts: 815
  • Yeah...I'm old school.
FAAAAAAACK!!!! I need British bike help!
« on: Mar 22, 2017, 19:24:03 »
 Ok, so I bought a 72 BSA Thunderbolt. Doesn't get much more simple. Single carb. Has E.I. Got here a little rough, I rebuilt the carb. charged the battery and it ran pretty well. Had a really shitty paint job and the tank was starting to seep, the petcocks were really tired and it had crappy mufflers. I had a set of really nice mufflers, and ordered a new tank and petcocks. I had the original tank cleaned and seams repaired.

 So today I button up the tank and petcocks, fill the bike with fuel and fire her up. Ran fine for a few minutes and then died and pissed a quart of oil on the floor. W.T.F. I clean up the oil and check the plugs which are dry. I try to fire it again and I'm getting so much kickback, it literally almost kicked me back over the bars. It back fired a few times and fired for a few seconds a few times. It sat over the winter, but without gas. I'm not sure where to start. I have a bad back and this kickback B.S. isn't helping. I need some input. I put it on a charger and walked away before I threw a match on it. It didn't smoke when running today...This is an O.I.F. bike. Any ideas???
"Do not neglect to show hospitality to strangers, for by this some have entertained angels without knowing it."

Offline beachcomber

  • DTT SUPPORTER
  • *
  • Posts: 3582
  • TJ - Beachcomber
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #1 on: Mar 23, 2017, 15:46:59 »
This is just a guess - someone like "Miffa" is probably yer man.

A lot of Brit bikes had a non return valve from the tank / frame. When these were left unstarted for a while the oil leaked back into the sump. Try draining the crank and see how much oil you get out.
"if at first you don't succeed, you've already been a failure once"

" we're not going back to the sixties - we never left "

"yep, nostalgia ain't what it used to be"

"I used to be indecisive - now I'm not so sure"

Offline ApriliaBill

  • Posts: 815
  • Yeah...I'm old school.
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #2 on: Mar 23, 2017, 16:58:54 »
 Update, found a ground wire came off, put that back and she fired, until it died. I started looking at the wiring and found a fuse between the ground and the negative side of the battery. Now when I say I found a fuse, it was literally taped between the wires. I went and bought a fuselink.

So I'm going to try and be as specific as a non electrical guy can be. There is a wire that runs from the side cover, it is attached to something I've never seen before, some metal thing that reminds me of and old G.M. sensor, it runs up under the seat into a fuselink and onto the negative side of the battery. Ok now the fuse that blew was 32V AGC35, the new link is a blade type 40 amp. after putting the 40 amp in, It won't fire.
« Last Edit: Mar 23, 2017, 21:45:57 by ApriliaBill »
"Do not neglect to show hospitality to strangers, for by this some have entertained angels without knowing it."

Offline teazer

  • DTT SUPPORTER
  • *
  • DTT BOTM WINNER
  • *
  • Posts: 8096
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #3 on: Mar 23, 2017, 17:17:09 »
Hm,

Which EI does it have - Boyer Bransden or other?  Can you show us any pictures of the odd parts? Is it +ve earth or -ve?


Offline julian.allard66

  • Posts: 259
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #4 on: Mar 23, 2017, 17:24:41 »
If a fuse is blowing you have a short somewhere.

Offline Sonreir™

  • Moderator
  • DTT SUPPORTER
  • *
  • Posts: 9930
  • Oregon
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #5 on: Mar 23, 2017, 17:26:47 »
1972 was still positive ground, correct?
Sparck Moto - http://www.sparckmoto.com

Audaces fortuna iuvat.

1977 Honda CJ360 - Café SOS - Stage One™, Café SOS - Stage Two™
1976 Puch Maxi - APuchalypse Now
Suzi T500 Cobra Resto

Custom Gauge Graphics
Custom Wiring Harnesses

DTT Red, White, and/or Black 360 Club - Better than those Blue guys

Offline ApriliaBill

  • Posts: 815
  • Yeah...I'm old school.
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #6 on: Mar 23, 2017, 17:54:33 »
 The lights, horn and blinkers are working, just doesn't want to fire...
"Do not neglect to show hospitality to strangers, for by this some have entertained angels without knowing it."

Offline ApriliaBill

  • Posts: 815
  • Yeah...I'm old school.
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #7 on: Mar 23, 2017, 17:56:00 »
...
"Do not neglect to show hospitality to strangers, for by this some have entertained angels without knowing it."

Offline Sonreir™

  • Moderator
  • DTT SUPPORTER
  • *
  • Posts: 9930
  • Oregon
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #8 on: Mar 23, 2017, 17:57:25 »
Verified that spark is the issue?

If you're sparking, have you checked timing? The kick-back is a classic symptom of having the timing advanced.
Sparck Moto - http://www.sparckmoto.com

Audaces fortuna iuvat.

1977 Honda CJ360 - Café SOS - Stage One™, Café SOS - Stage Two™
1976 Puch Maxi - APuchalypse Now
Suzi T500 Cobra Resto

Custom Gauge Graphics
Custom Wiring Harnesses

DTT Red, White, and/or Black 360 Club - Better than those Blue guys

Offline ApriliaBill

  • Posts: 815
  • Yeah...I'm old school.
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #9 on: Mar 23, 2017, 17:58:50 »
 Before winter, this bike ran fine. Wondering did I put the wrong type link in? Should it be an ATM instead of an ATC?
"Do not neglect to show hospitality to strangers, for by this some have entertained angels without knowing it."

Offline Tune-A-Fish©

  • DTT SUPPORTER
  • *
  • Posts: 6836
  • BOTM LOSER Proudly Deplorable
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #10 on: Mar 23, 2017, 18:48:29 »
Your going to be at the ATM a lot. I have a good brain box if that one took a dump might be a week or two before I can get to it tho.


Sent from my iPhone using DO THE TON
"I didn't come here and I ain't leavin"  Willie Nelson

"love hard, live fast, die fun" Kacey Musgraves

"Like a Wreckin Ball!" Eric Church

Offline teazer

  • DTT SUPPORTER
  • *
  • DTT BOTM WINNER
  • *
  • Posts: 8096
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #11 on: Mar 23, 2017, 19:44:59 »
That looks like the zener diode a.k.a. voltage regulator.

Offline apparatusmc

  • Posts: 4
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #12 on: Mar 23, 2017, 20:15:00 »
That looks like the zener diode a.k.a. voltage regulator.
Definitely the zener diode regulator
1. Disconnect the power leads to Boyer unit
2.turn power on to see if fuse still zaps
3. If it does, disconnect wire to zener
4. If this solves issue order a combination regulator/rectifier unit like a Tympanium, Ricks, etc.don't waste your time just doing the zener. You could also disconnect the output white lead from the rectumfrier to make sure it is not shorted
5. If you still have sparks in your shorts start looking for shorts.
Typical problem areas are in the rats nest under the tank, the headlight, and the crappy Lucas hi/lo beam switch on the handlebar. I just fixed one that blew the fuse every time I switched beams.

Skip


Sent from my iPad using Tapatalk

Offline ApriliaBill

  • Posts: 815
  • Yeah...I'm old school.
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #13 on: Mar 23, 2017, 20:35:04 »
 I'm kind of an idiot and probably not making myself clear. I'm not blowing fuses. The one that blew was literally taped at each end to the wires. I think it blew when the wire came off the "Zener" and arced on the frame. The lights, blinkers and horn are working fine. Right now, it seems to not be getting Fire. I'm going back out tomorrow to start checking stuff. The bike ran fine so I never bothered to check stuff (I know, I'm a Bonehead) and the wires were stuffed behind the battery. There is no rats nest under the tank, wires are in a tube. I haven't opened the headlight yet. Right now, looking at the easy stuff. Not quit sure what happened to running fine to no fire. I'll be looking at the suggestions and following your instructions hoping to hunt this down...
« Last Edit: Mar 23, 2017, 20:38:09 by ApriliaBill »
"Do not neglect to show hospitality to strangers, for by this some have entertained angels without knowing it."

Offline apparatusmc

  • Posts: 4
Re: FAAAAAAACK!!!! I need British bike help!
« Reply #14 on: Mar 23, 2017, 20:50:36 »
I'm kind of an idiot and probably not making myself clear. I'm not blowing fuses. The one that blew was literally taped at each end to the wires. I think it blew when the wire came off the "Zener" and arced on the frame. The lights, blinkers and horn are working fine. Right now, it seems to not be getting Fire. I'm going back put tomorrow to start check stuff. The bike ran fine so I never bothered to check stuff (I know, I'm a Bonehead) and the wires were stuffed behind the battery. There is no rats nest under the tank, wires are in a tube. I haven't opened the headlight yet. Right now looking at the easy stuff. Not quit sure what happened to running fine to no fire. I'll be looking at the suggestions and following your instructions hoping to hunt this down...
I understand...I may have overreacted because I have fixed so many cobbled up Brit wiring harnesses.  If all is ok with the battery hooked up, but no fire, it is either the wiring to the trigger unit, wiring to the coils, or the brain box itself. Take a look at the Boyer troubleshooting and installation sheet. You mentioned that it was kicking back before
finally ceasing to fire which makes me think the brain box may be bad. If you remove the plugs, hook them up, lay them on the head, and kick the bike over is there no spark, or is it just not starting.?
If you do have spark it may be as simple as the trigger Assy. has come loose and is way out of time.


Sent from my iPad using Tapatalk