collapse

www.dimecitycycles.com


www.restocycle.com

www.CITYLIMITMOTO.com

www.jadusmotorcycleparts.com

www.bisonmotorsports.com

www.speedmotoco.com

www.cognitomoto.com

www.townmoto.com

www.sparckmoto.com

www.Moto-Madness.com

www.pistonsociety.com

www.steeltowngarage.com


Author Topic: Turn signals not working  (Read 578 times)

Offline Xs7501978

  • Posts: 57
Re: Turn signals not working
« Reply #10 on: Sep 19, 2017, 10:48:46 »
Hmm how would I get to high of a voltage on 1 bulb? I know vibration isn't an issue because it burns out too fast for that to affect it


Sent from my iPhone using DO THE TON

Offline Sonreir

  • Moderator
  • DTT SUPPORTER
  • *
  • Posts: 10343
  • Oregon
Re: Turn signals not working
« Reply #11 on: Sep 20, 2017, 12:14:25 »
On just one bulb, it's not too likely.
« Last Edit: Sep 20, 2017, 13:17:50 by Sonreir™ »
Sparck Moto - http://www.sparckmoto.com

Audaces fortuna iuvat.

1977 Honda CJ360 - Café SOS - Stage One™, Café SOS - Stage Two™
1976 Puch Maxi - APuchalypse Now
Suzi T500 Cobra Resto

Custom Gauge Graphics
Custom Wiring Harnesses

DTT Red, White, and/or Black 360 Club - Better than those Blue guys

Offline Ryan Stecken

  • DTT SUPPORTER
  • *
  • DTT BOTM WINNER
  • *
  • Posts: 1779
Re: Turn signals not working
« Reply #12 on: Sep 20, 2017, 13:16:05 »
Following along.

Offline Xs7501978

  • Posts: 57
Re: Turn signals not working
« Reply #13 on: Sep 20, 2017, 22:13:23 »
Hmm well it looks like it started working again, it just flashes pretty fast now...I looked at the bulb and it looked burned out but now it seems to be working. I guess I need a led flasher relay for the smaller bulb


Sent from my iPhone using DO THE TON