collapse

www.dimecitycycles.com

www.cognitomoto.com

https://www.townmoto.com/collections/vanson-leathers

www.speedmotoco.com

www.CITYLIMITMOTO.com

www.jadusmotorcycleparts.com

www.lostapostlejewelry.com

www.sparckmoto.com

www.pistonsociety.com


Author Topic: Munit Blue on 84' CB650sc - Spark Plugs not firing  (Read 191 times)

Offline tdphoto

  • Posts: 2
Munit Blue on 84' CB650sc - Spark Plugs not firing
« on: Jul 09, 2019, 15:11:57 »
Stripped all the oem switches and replaced with motogadget buttons and munit blue and m-button.  Also replaced the reg/rec with a custom one from Ricks.  Used a Hella Relay from Revival to integrate with CDI.  After getting everything hooked up the started turns, but no spark from the plugs. I'm definitely missing something but can't figure out what it is.  The only thing I'm not 100% sure about is where the black wire coming from the reg/rec is supposed to go now that I don't have an engine stop switch anymore.  I've also got an extra wire that's integrated with the CDI that I think was put there by the previous owner.  It's labeled "On Motor" but currently it's not hooked up to anything and it's not listed in the OEM wiring diagram...it just come out of the stator along with the other 4 wires that are supposed to be there.  I've attached a very crude wiring diagram of what I'm trying to do as well as a few images of the wires in question.  Any help would be greatly appreciated as I know it's probably something really simple I'm missing.

Offline Sonreir

  • Moderator
  • DTT SUPPORTER
  • *
  • Posts: 11272
  • Oregon
Re: Munit Blue on 84' CB650sc - Spark Plugs not firing
« Reply #1 on: Jul 09, 2019, 18:32:57 »
OK... a few things about this one.

1.) Your bike doesn't have a CDI and so you don't need or want that relay. IGNITION output from the M-Unit should go the black/white wires from the coils and for the ignition unit.
2.) The spare black wire on the R/R is power and needs to go to the AUX output on the M-Unit so that it has power whenever the bike is turned on.
3.) Blue/red wire near the ignition unit is the negative wire from the oil pressure light.
Sparck Moto - http://www.sparckmoto.com

Audaces fortuna iuvat.

1977 Honda CJ360 - Café SOS - Stage One™, Café SOS - Stage Two™
1976 Puch Maxi - APuchalypse Now
Suzi T500 Cobra Resto

Custom Gauge Graphics
Custom Wiring Harnesses

DTT Red, White, and/or Black 360 Club - Better than those Blue guys

Offline tdphoto

  • Posts: 2
Re: Munit Blue on 84' CB650sc - Spark Plugs not firing
« Reply #2 on: Jul 09, 2019, 18:37:24 »
Thanks so much!  So yes...you are right...after doing a bit of digging it looks like there are some discrepancies across the internet as to whether the 650sc has a CDI ignition but it in fact has a transistorized ignition.  Thanks for the info on what the other two wires are...hopefully I can get this thing started again tonight.