[1982 Honda CB125S] Nearly completed LED 12v light conversion but cannot figure out this issue. (SUCCESS!)

RoyalRider

2010 Royal Enfield Bullet 500 - 1982 Honda CB125s
Hello everyone,

Hopefully people with good electrical knowledge can help out. I have a 1982 Honda CB125s and it came with a 6V system. I am trying to complete a 12v conversion but ran into an issue with the turning signals. The bike has a 12v front light, 12v battery, 12v rectifier regulator from Spark Moto, the correct LED flasher unit.

Motorcycles that use a single bulb for a turning signal indicator run into an issue when you convert to LED : all your indicators flash at once because power is recirculated to the other flashers. On motorcycles with left and right arrows for signal indicator on the dash this doesn't happen.

The solution provided is to splice in a diode kit into the front turning signals and dash indicator.

Two wires run from the indicator bulb, one orange and one baby blue. The instructions are to take the black ground from the diode kit and splice that from a ground wire to one of the two dash indicator wires. I spliced a green frame-ground wire to the orange wire from the indicator bulb. Then you take the kit's other wire that is a Y segment and you splice that into the other indicator wire and then the two ends to each respective right and left turn signal wire.

Here is a pic of my wiring diagram and the splice work I did on it : Here's the other side of the diagram if you need to consult :
After completing the job it should have worked but instead this is what happens :

When signaling left it correctly functions, when I signal right the rear brake light pulses and both right indicators stay off. I thought maybe it was the rear light and removed the bulb but that just stops it from functioning and the right indicators still don't function while left is okay.

From the video guides and the diode kit instructions it does not mention this possibility....they just mention that if it flashes too fast you need a different flasher unit but mine flash at the correct speed. I haven't tested it yet but I believe if I remove the dash bulb for indicators it might work but I want to be able to complete the conversion and keep the dash bulb functional.

Please let me know if the imgur links don't work and I can also go get pictures of the bike if needed.

Any help is greatly appreciated, I am capable of doing the actual splice and soldering work but am not a pro when it comes to understanding the principles behind electrical stuff.

Thanks for reading.
 

teazer

Over 10,000 Posts
DTT BOTM WINNER
Lots of bikes from that era had the single idiot light and with LED indicators, the power goes to one indicator and also though the light to the other side. That's where the diode kit comes into play. https://pinkpossum.com/Lights.htm but I'm sure that if you bought a kit from SparkMoto, then it should all work AS LONG as the diodes are inserted into the correct circuit.

It sounds like you may have spliced one side into the rear lamp circuit instead of the indicators, but an easy check is to remove the idiot light bulb and see if the system operates correctly. The diodes have to be inserted into the leads going to the idiot light both of which have to be cut. They cannot be spliced in with scotchlocks.
 

pidjones

Over 1,000 Posts
I ended up making my pure LED system work by placing a small (1N4007?) diode in series with each signal. So, takes 4 diodes and some connectors (I used bullets and sockets with shrink tubing on all of it) fixes it. Even my dash indicators are LED.
 

teazer

Over 10,000 Posts
DTT BOTM WINNER
Interesting solution. The issue is that in a conventional setup the idiot light is connected to both sides. With old school light bulbs that's not a problem because of the current draw and the time it takes to light the bulb, but with LEDs it basically makes both sides flash together.

The idea behind the twin diode approach is that power from one side to the flashers and idiot light cannot pass back down the other side to the other pair of flashers. With so many wires to deal with it can be confusing, but it's really simple if you take your time to identify the correct circuits. In this case, it looks like the right side was connected to the rear lamp and it's not clear from the description if wires to the idiot light were cut as they need to be or if they were spliced in parallel which won't work.
 

RoyalRider

2010 Royal Enfield Bullet 500 - 1982 Honda CB125s
Hello folks thanks for the replies that is much appreciated.
I used a pre-made diode kit that is meant for this and followed the exact instructions from this video :

I know 100% I did not splice into the rear light wiring. The rear light has 3 wires, one for the brake light switch (green yellow), a ground (green), and the brown lead that goes to the ignition switch and I absolutely did not splice into the brown wire.
My bike is parked in a garage separate from my apartment so I will go there tomorrow and test to see what happens when I remove the dash bulb. I'm also curious to see what happens if I disconnect the left side flashers wires and leave the right ones on (while also having the dash bulb back in)...curious to see if they will light up or not.
 

RoyalRider

2010 Royal Enfield Bullet 500 - 1982 Honda CB125s
Hi everyone,
So I can confirm that if I remove the dash bulb and try using the turning signals I get the exact same result; the rear stop light flashes and the right turning signals stay off. I forgot to disconnect the left side and see if right side works instead so apologies for that but I did also turn on the bike to see if there was any change while it was running and there was not.

Thanks for any advice.
 

teazer

Over 10,000 Posts
DTT BOTM WINNER
I understand why you are confused because it sounds like to did what was required and yet clearly the brake light is flashing when you try to indicate Right and that's confirmed by the fact that removing the rear bulb stops the flash at the rear but the right indicators still don't flash. We are all assuming here that the diagram matches your bike and that no prior owner mis-connected wires at some point. Is it possible that the rear light has been wrongly connected?

When you use the word "spliced" do you mean it connected through a scotchlock or similar or did you cut the wires to the indicator bulb or what I call the idiot light? Left is the orange circuit and right is Light Blue according to the diagrams you posted.
 

RoyalRider

2010 Royal Enfield Bullet 500 - 1982 Honda CB125s
Hmmm I don't think the previous owner messed up the wires, it all looks very OEM. This bike I have completely rebuilt down to the frame so I am familiar with the placement of the wires and the diagram but don't fully understand the concepts behind how it all works on a higher level. I have one of those common LED strips where it acts as a rear light and turning signals and I was able to connect that to the corresponding wires on the OEM harness and it works but exactly like the regular flashers do : once you switch to right the brake light flashes on the led strip instead of the right signal.

As for splicing the diode kit I did my best and braided the diode kit wires into the OEM wires then soldered the connections.

I'm sorry if I'm a bit disorganized I'm running on memory right now and don't have photos of the work I did but I am quite sure what I marked down on the image of my wiring diagram is correct, I'll try and confirm and take pics of the splicing job. In the tutorial video he said you can use either wire from the idiot light and I am quite sure I chose the blue wire which would be the right side. This makes me wonder if I had spliced into the orange wire if the left signals would not work and right would....

I had tried to use my multimeter to test my soldered connections to ensure they were good and I was getting readings but I set it to Ohms resistance and must admit I have no idea what I was doing. I only know how to use the darn thing when I follow tutorials....if you know what setting I should use on it to test the connections let me know I'll give that a shot.

Thanks.
 

teazer

Over 10,000 Posts
DTT BOTM WINNER
Two questions:

Did you cut the two wires to the indicator bulb?

Are you 110% sure that the LED strip is correctly wired into the main harness?
 

RoyalRider

2010 Royal Enfield Bullet 500 - 1982 Honda CB125s
I will get pictures tonight. The LED strip is causing confusion, it is not installed I am using the OEM lights right now. I only connected the LED strip as a test because I wondered if the rear brake light bulb was the cause. I wondered if maybe the LED strip had some diode in it or would correct the issue. It did not so I simply disconnected it and reconnected the OEM wires.

I'll get pics of the wires I spliced into etc.
 

RoyalRider

2010 Royal Enfield Bullet 500 - 1982 Honda CB125s
Okay I am embarrassed to say that the original wiring diagram with the explanation of how I wired in the diode was incorrect I had my wires mixed up (but according to the video it shouldn't matter). This is the correct wiring diagram and how it was done, the only difference is that I wired the ground wire into the blue indicator bulb wire not the orange. I also tested this and the result was interesting: I removed the left turning signal bullet connector from the 3-wire connector for it, which should disable it. However, because of the splicing from the diode kit the turning signals still flashed and received power.


I know I am going to get flak for this because this isn't professionally done or well done at all. I wanted to test that it worked before I went and got them covered up with shrink wrap/electrical tape etc.

Here is the black wire from the diode kit spliced into the frame ground wire to the blue indicator bulb wire :

Here are the turning signal wires that have the diode kits red wire (which has the actual diode) spliced into each of them and then spliced into the orange indicator bulb wire (note: its connected to the orange tube wire the little cutout of the diagram is wrong) :

The wire then turns dark blue and is spliced to the orange indicator wire:

Bonus pic of the bike as it sits now:

Thank you
 
Last edited:

pidjones

Over 1,000 Posts
Doesn't have to be pretty for testing. I used a lot of clip leads until I was satisfied on this Triumph that I'm working on. And held things in place in the headlight shell with hot glue .
 

teazer

Over 10,000 Posts
DTT BOTM WINNER
Looks like you added the diode wires to the existing wiring. You must cut both leads to the indicator bulb. the two wires from the bulb, one goes to the diode and the other to ground.

Then connect the two cut wires to the diode kit wires.

You should not need to splice anything in to the middle of the wires to the indicators.
 

RoyalRider

2010 Royal Enfield Bullet 500 - 1982 Honda CB125s
Please forgive me, I am an extremely visual learner bordering on disability so I need to try and visualize this via the wiring diagram.
Is this a correct interpretation of what you're saying I should do :

Describing the image above : I keep the black wire coming from the blue indicator bulb wire that connects to the green frame ground wire but then I must cut and eliminate the blue indicator bulb after that splice. Then for the orange indicator bulb wire I do the same where I cut it and eliminate it AFTER the joint for the diode that goes to the left/right turning signal wires. The little red X marks are to show the wire has been cut and eliminated from that point on.
 

teazer

Over 10,000 Posts
DTT BOTM WINNER
For some reason, the Imgur links don't work for me, so I can't grab your image and modify it. So let's try with words and see if that works. They say a picture is worth a thousand words, so get ready for a thousand or so words. :)

I think that most of us have difficulty understanding electrics, let alone electronics. But we usually get it right in the end.

Couple of comments. Your first image shows the diodes in the feed to the indicators. That's not how I do it. Your latest version has no connection to one side of the idiot light so that won't do the job either. I use the term "idiot light" to differentiate from the indicator bulbs which are what you replace with aftermarket LED bulbs or assemblies.

The diode kit should have three leads. One goes to each indicator circuit and the final one goes to the idiot light. The diodes act as one way "valves/gates" and allow power to flow in one direction only. Here's how I would wire it up:

Cut both leads to the idiot light along their length at a suitable spot. Connect the output from the diode pack to one side (orange) to the idiot light and connect the other (blue) wire from the idiot light to ground. Or Orange to ground and blue to diode pack. It doesn't matter which way round unless you also change teh idiot light for an LED.

Now connect one lead from the diode pack to the end of the cut orange lead from the flasher switch and the other leg to the cut blue lead.

So power flows from the main switch to the flasher can and from there to the indicator switch. Nothing changes there.

Power then flows from the switch to the left or right indicator bulbs. It also flows to the idiot light. It is only the idiot light wiring that we are changing. On a conventional light bulb circuit the idiot light is connected to both left and right sides and that won't work with LEDs. We have to cut the wires to the idiot light to prevent power from going back down to the other side circuit. We solder the diode pack into the idiot light circuit. We don't need to do anything with the wires from the switch to the indicator bulbs. Just the "idiot light"

Hope that makes more sense.
 

RoyalRider

2010 Royal Enfield Bullet 500 - 1982 Honda CB125s
Thank you kindly Teazer you are really great for taking the time to explain.
Okay I will mull this over and attempt to do it as you described and come back with results for you folks. I have a long weekend so I hope to have time to do it. I really, really appreciate your assistance. I will also try and re-upload the pics with something that works better than imgur because me too I'm having trouble loading them when I click on the image but I can see them embedded in my posts so that's weird.
Anywho, I will give it a shot.

Cheers
 

benroloff

Been Around the Block
I actually just did this on my 1970 cl100, which should be wired basically the same as your bike, so I will try to explain how I did it. As teaser said, you should first cut the two wires that go to the “idiot light”. Since you cut these two wires, you will now have 4 ends of wires that are unconnected. Two that go to the light, and two that go back into the wiring harness. You will connect the two that go back into the harness to the two inputs of the diode kit. You will connect the output of the diode kit to one of the wires that goes to the light. I connected the diode output to the orange wire that goes to the light, however you can connect it to whichever you want, it does not matter. Now you should have only one open connection, the other wire that goes to the light. This just needs to be connected to a solid ground, wherever you can make that work.
Hopefully that helped, and didn’t cause any more confusion!


Sent from my iPhone using DO THE TON
 

teazer

Over 10,000 Posts
DTT BOTM WINNER
Nice and clear. Thanks benroloff.
 

Attachments

  • 277568105_5056354717787276_3070685123254246588_n.jpg
    277568105_5056354717787276_3070685123254246588_n.jpg
    49.2 KB · Views: 25

RoyalRider

2010 Royal Enfield Bullet 500 - 1982 Honda CB125s
Thank you Teazer and thank you Benroloff. Those are both great explanations but I must admit that Benroloff's explanation made sense in my mind's eye. Sorry for the lack of update, I am also trying to bring back to life a 1985 RX7 FB and recently pulled the intake/carb on that and now am doing the exhaust so both can get fresh gaskets.
But I think I know what to do now, hopefully next update is just good news from me :)

Many thanks, excited to get this bike back on the road with proper lights.
 

DTT Bike Of The Month Gallery

DTT Light or Dark

www.jadusmotorcycleparts.com
www.cognitomoto.com
https://www.townmoto.com
www.speedmotoco.com
www.lostapostle.ca/
www.sparckmoto.com
Top Bottom